AFUP AFUP Day 2021 Baromètre Planète PHP
 

La fin du support de PHP 4 est annoncé

4 août 2007

Vous pouvez facilement tester la compatibilité PHP 5 de vos applications (sous Windows) en utilisant l'auto installeur PHP MySQL WampServer qui, installé avec son module PHP 4, permet de switcher de PHP 4 vers PHP 5 et vice versa.

Le 13 Juillet 2007 cela fera exactement trois ans que PHP 5 est en version de production. Durant ces trois années de nombreuses améliorations ont été faites pour PHP 4. PHP 5 est rapide, stable et apte à la production. De plus PHP 6 est en cours de réalisation. Pour toutes ces raisons le PHPGroup annonce que le support de PHP 4 ne va continuer que jusqu'à la fin de l'année. Après le 31 décembre 2007 il n'y aura plus de nouvelles versions de PHP 4.4. Bien entendu les éventuelles failles de sécurités seront traitées mais au cas par cas jusqu'au 8 août 2008. Profitez de ce délai pour valider que vos applications sont compatibles PHP 5. De la documentation sur la migration de PHP 4 à PHP 5 est disponible sous la forme d'un guide de migration. La migration des applications d'entreprises peut être accompagnée par l'un des nombreux prestataires PHP. Une liste non exhaustive est disponible sur l'annuaire PHP de l'AFUP.


Thème : L'AFUP soutient / Année : 2007